mscorlib

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

mscorlib

Ernesto Rodriguez
Dear All,

I compiled mono 3.4.0 from source but the only instance of mscorlib.dll I get is located at:

lib/mono/2.0/mscorlib.dll

However, I wish to run a program that requires mscorlib 4.5. I am not clear on how to obtain such version from mscorlib. I would appreciate if someone would explain this to me.

Best regards,

--
Ernesto Rodriguez

Masters Student
Computer Science
Utrecht University




_______________________________________________
Mono-list maillist  -  [hidden email]
http://lists.ximian.com/mailman/listinfo/mono-list
Reply | Threaded
Open this post in threaded view
|

Re: mscorlib

Edward Ned Harvey (mono)
> From: [hidden email] [mailto:mono-list-
> [hidden email]] On Behalf Of Ernesto Rodriguez
>
> I compiled mono 3.4.0 from source but the only instance of mscorlib.dll I get
> is located at:
>
> lib/mono/2.0/mscorlib.dll

Sounds like a failed build to me.  I would suggest first "make clean" and then, I like to chain all the configure / make commands with && so if any of them fail, I can actually see that in the output.

./configure && make && sudo make install && echo "" && echo "" && echo "Build Succeeded" && echo ""
_______________________________________________
Mono-list maillist  -  [hidden email]
http://lists.ximian.com/mailman/listinfo/mono-list