gactestlib.dll

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gactestlib.dll

Neale Ferguson
+ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- font-family: Calibri, sans-serif+ADs- font-size: 14px+ADs- color: rgb(0, 0, 0)+ADsAIgA+- +ADw-div+AD4-I build from head for s390x and running tests came across this error:+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-make+AFs-5+AF0-: Entering directory +AGA-/home/neale/Mono/mono/mono/tests/testing+AF8-gac'+ADw-/div+AD4- +ADw-div+AD4-MONO+AF8-PATH+AD0-/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper /home/neale/Mono/mono/mcs/class/lib/build/mcs.exe -noconfig -nologo -debug:portable -target:library+ACY-nbsp+ADsAJg-nbsp+ADs--target:exe -out:app-both.exe -r:V1+AD0-signed+AF8-v1/gactestlib.dll /r:V2+AD0-signed+AF8-v2/gactestlib.dll app-both.cs+ADw-/div+AD4- +ADw-div+AD4-error CS1703: An assembly +AGA-gactestlib' with the same identity has already been imported. Consider removing one of the references+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v1/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v2/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-Compilation failed: 1 error(s), 0 warnings+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Any idea of what I may have done wrong?+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Neale+ADw-/div+AD4- +ADw-/body+AD4- +ADw-/html+AD4-
_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gactestlib.dll

Neale Ferguson

F$*cking Outlook for Mac. Here's the original text:


I build from head for s390x and running tests came across this error:

make[5]: Entering directory `/home/neale/Mono/mono/mono/tests/testing_gac'
MONO_PATH=/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper /home/neale/Mono/mono/mcs/class/lib/build/mcs.exe -noconfig -nologo -debug:portable -target:library  -target:exe -out:app-both.exe -r:V1=signed_v1/gactestlib.dll /r:V2=signed_v2/gactestlib.dll app-both.cs
error CS1703: An assembly `gactestlib' with the same identity has already been imported. Consider removing one of the references
signed_v1/gactestlib.dll (Location of the symbol related to previous error)
signed_v2/gactestlib.dll (Location of the symbol related to previous error)
Compilation failed: 1 error(s), 0 warnings

Any idea of what I may have done wrong?

Neale


From: Brandon Perry <[hidden email]>
Sent: Sunday, August 6, 2017 9:17:57 AM
To: Neale Ferguson
Subject: Re: [Mono-dev] gactestlib.dll
 
Hi Neale, your emails come through (to me at least) very messed up; see below. I’m not sure if others are getting these as well, but I don’t see why they wouldn’t.

> On Aug 6, 2017, at 8:49 AM, Neale Ferguson <[hidden email]> wrote:
>
> +ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- font-family: Calibri, sans-serif+ADs- font-size: 14px+ADs- color: rgb(0, 0, 0)+ADsAIgA+- +ADw-div+AD4-I build from head for s390x and running tests came across this error:+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-make+AFs-5+AF0-: Entering directory +AGA-/home/neale/Mono/mono/mono/tests/testing+AF8-gac'+ADw-/div+AD4- +ADw-div+AD4-MONO+AF8-PATH+AD0-/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper /home/neale/Mono/mono/mcs/class/lib/build/mcs.exe -noconfig -nologo -debug:portable -target:library+ACY-nbsp+ADsAJg-nbsp+ADs--target:exe -out:app-both.exe -r:V1+AD0-signed+AF8-v1/gactestlib.dll /r:V2+AD0-signed+AF8-v2/gactestlib.dll app-both.cs+ADw-/div+AD4- +ADw-div+AD4-error CS1703: An assembly +AGA-gactestlib' with the same identity has already been imported. Consider removing one of the references+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v1/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v2/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-Compilation failed: 1 error(s), 0 warnings+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Any idea of what I may have done wrong?+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Neale+ADw-/div+AD4- +ADw-/body+AD4- +ADw-/html+AD4- _______________________________________________
> Mono-devel-list mailing list
> [hidden email]
> http://lists.dot.net/mailman/listinfo/mono-devel-list


_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gactestlib.dll

Alexander Köplinger via Mono-devel-list

Looks like a bug in mcs.  signed_v1/gactestlib.dll and signed_v2/gactestlib.dll both have the same name and public key token, but different versions - they should be treated as distinct libraries.  I filed https://bugzilla.xamarin.com/show_bug.cgi?id=58621

 

-Aleksey

 

On 8/6/17, 10:23, "Mono-devel-list on behalf of Neale Ferguson" <[hidden email] on behalf of [hidden email]> wrote:

 

F$*cking Outlook for Mac. Here's the original text:

 

I build from head for s390x and running tests came across this error:

 

make[5]: Entering directory `/home/neale/Mono/mono/mono/tests/testing_gac'

MONO_PATH=/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper /home/neale/Mono/mono/mcs/class/lib/build/mcs.exe -noconfig -nologo -debug:portable -target:library  -target:exe -out:app-both.exe -r:V1=signed_v1/gactestlib.dll /r:V2=signed_v2/gactestlib.dll app-both.cs

error CS1703: An assembly `gactestlib' with the same identity has already been imported. Consider removing one of the references

signed_v1/gactestlib.dll (Location of the symbol related to previous error)

signed_v2/gactestlib.dll (Location of the symbol related to previous error)

Compilation failed: 1 error(s), 0 warnings

 

Any idea of what I may have done wrong?

 

Neale

 


From: Brandon Perry <[hidden email]>
Sent: Sunday, August 6, 2017 9:17:57 AM
To: Neale Ferguson
Subject: Re: [Mono-dev] gactestlib.dll

 

Hi Neale, your emails come through (to me at least) very messed up; see below. I’m not sure if others are getting these as well, but I don’t see why they wouldn’t.

> On Aug 6, 2017, at 8:49 AM, Neale Ferguson <[hidden email]> wrote:
>
> +ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- font-family: Calibri, sans-serif+ADs- font-size: 14px+ADs- color: rgb(0, 0, 0)+ADsAIgA+- +ADw-div+AD4-I build from head for s390x and running tests came across this error:+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-make+AFs-5+AF0-: Entering directory +AGA-/home/neale/Mono/mono/mono/tests/testing+AF8-gac'+ADw-/div+AD4- +ADw-div+AD4-MONO+AF8-PATH+AD0-/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper /home/neale/Mono/mono/mcs/class/lib/build/mcs.exe -noconfig -nologo -debug:portable -target:library+ACY-nbsp+ADsAJg-nbsp+ADs--target:exe -out:app-both.exe -r:V1+AD0-signed+AF8-v1/gactestlib.dll /r:V2+AD0-signed+AF8-v2/gactestlib.dll app-both.cs+ADw-/div+AD4- +ADw-div+AD4-error CS1703: An assembly +AGA-gactestlib' with the same identity has already been imported. Consider removing one of the references+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v1/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-signed+AF8-v2/gactestlib.dll (Location of the symbol related to previous error)+ADw-/div+AD4- +ADw-div+AD4-Compilation failed: 1 error(s), 0 warnings+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Any idea of what I may have done wrong?+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Neale+ADw-/div+AD4- +ADw-/body+AD4- +ADw-/html+AD4- _______________________________________________
> Mono-devel-list mailing list
> [hidden email]
> http://lists.dot.net/mailman/listinfo/mono-devel-list


_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Loading...