app-refl-load

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

app-refl-load

Neale Ferguson
This test fails on s390x with Rc=1 which indicates that
AppDomain.CurrentDomain.Load (n) is returning NULL. What type of things
should I look for?

_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: app-refl-load

Alexander Köplinger via Mono-devel-list

Neale,

 

That test is run in a couple of different configurations (see mono/tests/testing_gac/Makefile.am) which try to test loading strongly named assemblies either from the MONO_PATH or from the Mono GAC, occasionally when there are other versions of the same assembly (ie, same simple name, same public key token, different Version) also in the GAC or on the MONO_PATH.

So the first thing to figure out is which instance of the test is failing.   If you run make with V=1 it should print out the exact command that it tries to run.

 

In any case exit code of 1 means AppDomain.CurrentDomain.Load(AssemblyName) returned null for some reason.

 

I find it helpful to set MONO_LOG_MASK=asm MONO_LOG_LEVEL=debug when running loader tests to figure out what’s going on.

 

Cheers,

Aleksey

On 8/29/17, 15:29, "Mono-devel-list on behalf of Neale Ferguson" <[hidden email] on behalf of [hidden email]> wrote:

 

This test fails on s390x with Rc=1 which indicates that

AppDomain.CurrentDomain.Load (n) is returning NULL. What type of things

should I look for?

 

_______________________________________________

Mono-devel-list mailing list

 


_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: app-refl-load

Alexander Köplinger via Mono-devel-list

Oh, one other thing: the tests run via the test-runner.exe (*) so if you just set the MONO_LOG_{MASK,LEVEL} vars, you’ll get the loader behavior for the test runner not the test.  So what you really want to do is figure out how the test runner invokes mono to run the test. (Basically --runtime commandinline arg of the test runner is the mono to invoke to start the testcase, --runtime-args are args to pass to it, --mono-path and --mono-gac-prefix are MONO_PATH and MONO_GAC_PREFIX environment vars to set for the testcase).  I should’ve made it easier to just run the bare test, sorry.

 

(*): the test runner babysits the tests and kills them when they time out, collects output and writes TestResult-*.xml files for Jenkins to consume.

 

-Aleksey

 

On 8/29/17, 15:46, "Mono-devel-list on behalf of Aleksey Kliger via Mono-devel-list" <[hidden email] on behalf of [hidden email]> wrote:

 

Neale,

 

That test is run in a couple of different configurations (see mono/tests/testing_gac/Makefile.am) which try to test loading strongly named assemblies either from the MONO_PATH or from the Mono GAC, occasionally when there are other versions of the same assembly (ie, same simple name, same public key token, different Version) also in the GAC or on the MONO_PATH.

So the first thing to figure out is which instance of the test is failing.   If you run make with V=1 it should print out the exact command that it tries to run.

 

In any case exit code of 1 means AppDomain.CurrentDomain.Load(AssemblyName) returned null for some reason.

 

I find it helpful to set MONO_LOG_MASK=asm MONO_LOG_LEVEL=debug when running loader tests to figure out what’s going on.

 

Cheers,

Aleksey

On 8/29/17, 15:29, "Mono-devel-list on behalf of Neale Ferguson" <[hidden email] on behalf of [hidden email]> wrote:

 

This test fails on s390x with Rc=1 which indicates that

AppDomain.CurrentDomain.Load (n) is returning NULL. What type of things

should I look for?

 

_______________________________________________

Mono-devel-list mailing list

 


_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: app-refl-load

Neale Ferguson
In reply to this post by Alexander Köplinger via Mono-devel-list
+ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- color: rgb(0, 0, 0)+ADs- font-size: 14px+ADs- font-family: Calibri, sans-serif+ADsAIgA+- +ADw-div+AD4-Thanks.+ACY-nbsp+ADsAPA-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-I see it passing -+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4- +ADw-p style+AD0AIg-margin: 0px+ADs- font-size: 18px+ADs- line-height: normal+ADs- font-family: 'Courier New'+ADs- background-color: rgb(255, 254, 229)+ADsAIgA+- +ADw-span style+AD0AIg-font-variant-ligatures: no-common-ligatures+ACIAPg---testsuite-name +ACY-quot+ADs-testing+AF8-gac+AF8-test-signed-v1-app-mp-unsigned-v1+ACY-quot+ADsAPA-/span+AD4APA-/p+AD4- +ADw-/div+AD4- +ADw-div+AD4- +ADw-p style+AD0AIg-margin: 0px+ADs- font-size: 18px+ADs- line-height: normal+ADs- font-family: 'Courier New'+ADs- background-color: rgb(255, 254, 229)+ADsAIgA+- +ADw-span style+AD0AIg-font-variant-ligatures: no-common-ligatures+ACIAPg---testsuite-name +ACY-quot+ADs-testing+AF8-gac+AF8-test-signed-v1-app-mp-signed-v1+ACY-quot+ADsAPA-/span+AD4APA-/p+AD4- +ADw-/div+AD4- +ADw-div+AD4- +ADw-p style+AD0AIg-margin: 0px+ADs- font-size: 18px+ADs- line-height: normal+ADs- font-family: 'Courier New'+ADs- background-color: rgb(255, 254, 229)+ADsAIgA+- +ADw-span style+AD0AIg-font-variant-ligatures: no-common-ligatures+ACIAPg---testsuite-name +ACY-quot+ADs-testing+AF8-gac+AF8-test-signed-v1-app-mp-unsigned-v2-signed-v1+ACY-quot+ADsAPA-/span+AD4APA-/p+AD4- +ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-And failing when:+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4- +ADw-p style+AD0AIg-margin: 0px+ADs- font-size: 18px+ADs- line-height: normal+ADs- font-family: 'Courier New'+ADs- background-color: rgb(255, 254, 229)+ADsAIgA+- +ADw-span style+AD0AIg-font-variant-ligatures: no-common-ligatures+ACIAPg---testsuite-name +ACY-quot+ADs-testing+AF8-gac+AF8-test-signed-v1-app-mp-signed-v2-signed-v1+ACY-quot+ADsAPA-/span+AD4APA-/p+AD4- +ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-There+IBk-s nothing in the verbose output of the working and non-working cases that differ or give me a hint of what+IBk-s not working.+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-Neale+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-span id+AD0AIg-OLK+AF8-SRC+AF8-BODY+AF8-SECTION+ACIAPg- +ADw-div style+AD0AIg-font-family:Calibri+ADs- font-size:11pt+ADs- text-align:left+ADs- color:black+ADs- BORDER-BOTTOM: medium none+ADs- BORDER-LEFT: medium none+ADs- PADDING-BOTTOM: 0in+ADs- PADDING-LEFT: 0in+ADs- PADDING-RIGHT: 0in+ADs- BORDER-TOP: +ACM-b5c4df 1pt solid+ADs- BORDER-RIGHT: medium none+ADs- PADDING-TOP: 3pt+ACIAPg- +ADw-br+AD4- +ADw-/div+AD4- +ADw-div xmlns:o+AD0AIg-urn:schemas-microsoft-com:office:office+ACI- xmlns:w+AD0AIg-urn:schemas-microsoft-com:office:word+ACI- xmlns:m+AD0AIg-http://schemas.microsoft.com/office/2004/12/omml+ACI- xmlns+AD0AIg-http://www.w3.org/TR/REC-html40+ACIAPg- +ADw-meta name+AD0AIg-Title+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Keywords+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Generator+ACI- content+AD0AIg-Microsoft Word 15 (filtered medium)+ACIAPg- +ADw-style+AD4APAAh--- /+ACo- Font Definitions +ACo-/ +AEA-font-face +AHs-font-family:+ACI-Cambria Math+ACIAOw- panose-1:2 4 5 3 5 4 6 3 2 4+ADsAfQ- +AEA-font-face +AHs-font-family:Calibri+ADs- panose-1:2 15 5 2 2 2 4 3 2 4+ADsAfQ- /+ACo- Style Definitions +ACo-/ p.MsoNormal, li.MsoNormal, div.MsoNormal +AHs-margin:0in+ADs- margin-bottom:.0001pt+ADs- font-size:11.0pt+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADsAfQ- a:link, span.MsoHyperlink +AHs-mso-style-priority:99+ADs- color:blue+ADs- text-decoration:underline+ADsAfQ- a:visited, span.MsoHyperlinkFollowed +AHs-mso-style-priority:99+ADs- color:purple+ADs- text-decoration:underline+ADsAfQ- span.EmailStyle17 +AHs-mso-style-type:personal-reply+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADs- color:windowtext+ADsAfQ- span.msoIns +AHs-mso-style-type:export-only+ADs- mso-style-name:+ACIAIgA7- text-decoration:underline+ADs- color:teal+ADsAfQ- .MsoChpDefault +AHs-mso-style-type:export-only+ADs- font-size:10.0pt+ADsAfQ- +AEA-page WordSection1 +AHs-size:8.5in 11.0in+ADs- margin:1.0in 1.0in 1.0in 1.0in+ADsAfQ- div.WordSection1 +AHs-page:WordSection1+ADsAfQ- --+AD4APA-/style+AD4- +ADw-div bgcolor+AD0AIg-white+ACI- lang+AD0AIg-EN-US+ACI- link+AD0AIg-blue+ACI- vlink+AD0AIg-purple+ACIAPg- +ADw-div class+AD0AIg-WordSection1+ACIAPg- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-Neale,+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPgA8-o:p+AD4AJg-nbsp+ADsAPA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-That test is run in a couple of different configurations (see mono/tests/testing+AF8-gac/Makefile.am) which try to test loading strongly named assemblies either from the MONO+AF8-PATH or from the Mono GAC, occasionally when there are other versions of the same assembly (ie, same simple name, same public key token, different Version) also in the GAC or on the MONO+AF8-PATH.+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-So the first thing to figure out is which instance of the test is failing.+ACY-nbsp+ADsAJg-nbsp+ADs- If you run make with V+AD0-1 it should print out the exact command that it tries to run.+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPgA8-o:p+AD4AJg-nbsp+ADsAPA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-In any case exit code of 1 means AppDomain.CurrentDomain.Load(AssemblyName) returned null for some reason.+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPgA8-o:p+AD4AJg-nbsp+ADsAPA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-I find it helpful to set MONO+AF8-LOG+AF8-MASK+AD0-asm MONO+AF8-LOG+AF8-LEVEL+AD0-debug when running loader tests to figure out what+IBk-s going on.+ADw-/p+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/span+AD4- +ADw-/body+AD4- +ADw-/html+AD4-
_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: app-refl-load

Neale Ferguson
In reply to this post by Alexander Köplinger via Mono-devel-list
+ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- color: rgb(0, 0, 0)+ADs- font-size: 14px+ADs- font-family: Calibri, sans-serif+ADsAIgA+- +ADw-div+AD4-Just saw this after I pressed send on the last reply.+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-span id+AD0AIg-OLK+AF8-SRC+AF8-BODY+AF8-SECTION+ACIAPg- +ADw-div style+AD0AIg-font-family:Calibri+ADs- font-size:11pt+ADs- text-align:left+ADs- color:black+ADs- BORDER-BOTTOM: medium none+ADs- BORDER-LEFT: medium none+ADs- PADDING-BOTTOM: 0in+ADs- PADDING-LEFT: 0in+ADs- PADDING-RIGHT: 0in+ADs- BORDER-TOP: +ACM-b5c4df 1pt solid+ADs- BORDER-RIGHT: medium none+ADs- PADDING-TOP: 3pt+ACIAPg- +ADw-br+AD4- +ADw-/div+AD4- +ADw-div xmlns:o+AD0AIg-urn:schemas-microsoft-com:office:office+ACI- xmlns:w+AD0AIg-urn:schemas-microsoft-com:office:word+ACI- xmlns:m+AD0AIg-http://schemas.microsoft.com/office/2004/12/omml+ACI- xmlns+AD0AIg-http://www.w3.org/TR/REC-html40+ACIAPg- +ADw-meta name+AD0AIg-Title+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Keywords+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Generator+ACI- content+AD0AIg-Microsoft Word 15 (filtered medium)+ACIAPg- +ADw-style+AD4APAAh--- /+ACo- Font Definitions +ACo-/ +AEA-font-face +AHs-font-family:+ACI-Cambria Math+ACIAOw- panose-1:2 4 5 3 5 4 6 3 2 4+ADsAfQ- +AEA-font-face +AHs-font-family:Calibri+ADs- panose-1:2 15 5 2 2 2 4 3 2 4+ADsAfQ- /+ACo- Style Definitions +ACo-/ p.MsoNormal, li.MsoNormal, div.MsoNormal +AHs-margin:0in+ADs- margin-bottom:.0001pt+ADs- font-size:11.0pt+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADsAfQ- a:link, span.MsoHyperlink +AHs-mso-style-priority:99+ADs- color:blue+ADs- text-decoration:underline+ADsAfQ- a:visited, span.MsoHyperlinkFollowed +AHs-mso-style-priority:99+ADs- color:purple+ADs- text-decoration:underline+ADsAfQ- span.EmailStyle17 +AHs-mso-style-type:personal+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADs- color:windowtext+ADsAfQ- span.EmailStyle18 +AHs-mso-style-type:personal-reply+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADs- color:windowtext+ADsAfQ- span.msoIns +AHs-mso-style-type:export-only+ADs- mso-style-name:+ACIAIgA7- text-decoration:underline+ADs- color:teal+ADsAfQ- .MsoChpDefault +AHs-mso-style-type:export-only+ADs- font-size:10.0pt+ADsAfQ- +AEA-page WordSection1 +AHs-size:8.5in 11.0in+ADs- margin:1.0in 1.0in 1.0in 1.0in+ADsAfQ- div.WordSection1 +AHs-page:WordSection1+ADsAfQ- --+AD4APA-/style+AD4- +ADw-div bgcolor+AD0AIg-white+ACI- lang+AD0AIg-EN-US+ACI- link+AD0AIg-blue+ACI- vlink+AD0AIg-purple+ACIAPg- +ADw-div class+AD0AIg-WordSection1+ACIAPg- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-Oh, one other thing: the tests run via the test-runner.exe (+ACo-) so if you just set the MONO+AF8-LOG+AF8Aew-MASK,LEVEL+AH0- vars, you+IBk-ll get the loader behavior for the test runner not the test.+ACY-nbsp+ADs- So what you really want to do is figure out how the test runner invokes mono to run the test. (Basically --runtime commandinline arg of the test runner is the mono to invoke to start the testcase, --runtime-args are args to pass to it, --mono-path and --mono-gac-prefix are MONO+AF8-PATH and MONO+AF8-GAC+AF8-PREFIX environment vars to set for the testcase).+ACY-nbsp+ADs- I should+IBk-ve made it easier to just run the bare test, sorry.+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPgA8-o:p+AD4AJg-nbsp+ADsAPA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-(+ACo-): the test runner babysits the tests and kills them when they time out, collects output and writes TestResult-+ACo-.xml files for Jenkins to consume.+ADw-/p+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/span+AD4- +ADw-/body+AD4- +ADw-/html+AD4-
_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: app-refl-load

Neale Ferguson
In reply to this post by Alexander Köplinger via Mono-devel-list
+ADw-html+AD4- +ADw-head+AD4- +ADw-/head+AD4- +ADw-body style+AD0AIg-word-wrap: break-word+ADs- -webkit-nbsp-mode: space+ADs- -webkit-line-break: after-white-space+ADs- color: rgb(0, 0, 0)+ADs- font-size: 14px+ADs- font-family: Calibri, sans-serif+ADsAIgA+- +ADw-div+AD4-I got it to run using:+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4- +ADw-p style+AD0AIg-margin: 0px+ADs- font-size: 18px+ADs- line-height: normal+ADs- font-family: 'Courier New'+ADs- background-color: rgb(255, 254, 229)+ADsAIgA+- +ADw-span style+AD0AIg-font-variant-ligatures: no-common-ligatures+ACIAPg-MONO+AF8-LOG+AF8-MASK+AD0-all MONO+AF8-LOG+AF8-LEVEL+AD0-debug MONO+AF8-PATH+AD0-signed+AF8-v2:signed+AF8-v1:/home/neale/Mono/mono/mcs/class/lib/build ../../../runtime/mono-wrapper app-refl-load-v1.exe+ADw-/span+AD4APA-/p+AD4- +ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-div+AD4-There is nothing obvious in the debug output for the working versus the non-working cases.+ADw-/div+AD4- +ADw-div+AD4APA-br+AD4- +ADw-/div+AD4- +ADw-span id+AD0AIg-OLK+AF8-SRC+AF8-BODY+AF8-SECTION+ACIAPg- +ADw-div style+AD0AIg-font-family:Calibri+ADs- font-size:11pt+ADs- text-align:left+ADs- color:black+ADs- BORDER-BOTTOM: medium none+ADs- BORDER-LEFT: medium none+ADs- PADDING-BOTTOM: 0in+ADs- PADDING-LEFT: 0in+ADs- PADDING-RIGHT: 0in+ADs- BORDER-TOP: +ACM-b5c4df 1pt solid+ADs- BORDER-RIGHT: medium none+ADs- PADDING-TOP: 3pt+ACIAPg- +ADw-br+AD4- +ADw-/div+AD4- +ADw-div xmlns:o+AD0AIg-urn:schemas-microsoft-com:office:office+ACI- xmlns:w+AD0AIg-urn:schemas-microsoft-com:office:word+ACI- xmlns:m+AD0AIg-http://schemas.microsoft.com/office/2004/12/omml+ACI- xmlns+AD0AIg-http://www.w3.org/TR/REC-html40+ACIAPg- +ADw-meta name+AD0AIg-Title+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Keywords+ACI- content+AD0AIgAiAD4- +ADw-meta name+AD0AIg-Generator+ACI- content+AD0AIg-Microsoft Word 15 (filtered medium)+ACIAPg- +ADw-style+AD4APAAh--- /+ACo- Font Definitions +ACo-/ +AEA-font-face +AHs-font-family:+ACI-Cambria Math+ACIAOw- panose-1:2 4 5 3 5 4 6 3 2 4+ADsAfQ- +AEA-font-face +AHs-font-family:Calibri+ADs- panose-1:2 15 5 2 2 2 4 3 2 4+ADsAfQ- /+ACo- Style Definitions +ACo-/ p.MsoNormal, li.MsoNormal, div.MsoNormal +AHs-margin:0in+ADs- margin-bottom:.0001pt+ADs- font-size:11.0pt+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADsAfQ- a:link, span.MsoHyperlink +AHs-mso-style-priority:99+ADs- color:blue+ADs- text-decoration:underline+ADsAfQ- a:visited, span.MsoHyperlinkFollowed +AHs-mso-style-priority:99+ADs- color:purple+ADs- text-decoration:underline+ADsAfQ- span.EmailStyle17 +AHs-mso-style-type:personal+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADs- color:windowtext+ADsAfQ- span.EmailStyle18 +AHs-mso-style-type:personal-reply+ADs- font-family:+ACI-Calibri+ACI-,sans-serif+ADs- color:windowtext+ADsAfQ- span.msoIns +AHs-mso-style-type:export-only+ADs- mso-style-name:+ACIAIgA7- text-decoration:underline+ADs- color:teal+ADsAfQ- .MsoChpDefault +AHs-mso-style-type:export-only+ADs- font-size:10.0pt+ADsAfQ- +AEA-page WordSection1 +AHs-size:8.5in 11.0in+ADs- margin:1.0in 1.0in 1.0in 1.0in+ADsAfQ- div.WordSection1 +AHs-page:WordSection1+ADsAfQ- --+AD4APA-/style+AD4- +ADw-div bgcolor+AD0AIg-white+ACI- lang+AD0AIg-EN-US+ACI- link+AD0AIg-blue+ACI- vlink+AD0AIg-purple+ACIAPg- +ADw-div class+AD0AIg-WordSection1+ACIAPg- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-Oh, one other thing: the tests run via the test-runner.exe (+ACo-) so if you just set the MONO+AF8-LOG+AF8Aew-MASK,LEVEL+AH0- vars, you+IBk-ll get the loader behavior for the test runner not the test.+ACY-nbsp+ADs- So what you really want to do is figure out how the test runner invokes mono to run the test. (Basically --runtime commandinline arg of the test runner is the mono to invoke to start the testcase, --runtime-args are args to pass to it, --mono-path and --mono-gac-prefix are MONO+AF8-PATH and MONO+AF8-GAC+AF8-PREFIX environment vars to set for the testcase).+ACY-nbsp+ADs- I should+IBk-ve made it easier to just run the bare test, sorry.+ADw-o:p+AD4APA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPgA8-o:p+AD4AJg-nbsp+ADsAPA-/o:p+AD4APA-/p+AD4- +ADw-p class+AD0AIg-MsoNormal+ACIAPg-(+ACo-): the test runner babysits the tests and kills them when they time out, collects output and writes TestResult-+ACo-.xml files for Jenkins to consume.+ADw-/p+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/div+AD4- +ADw-/span+AD4- +ADw-/body+AD4- +ADw-/html+AD4-
_______________________________________________
Mono-devel-list mailing list
[hidden email]
http://lists.dot.net/mailman/listinfo/mono-devel-list