Problems with building the project without CMake

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with building the project without CMake

Andy1988
This post has NOT been accepted by the mailing list yet.
Hi everyone,

I am currently working on a project using equalizer. I tried to use CMake (Buildyard) to build the whole equalizer project from github. That works all fine. The thing is, I want to use the installed libraries of equalizer in my system libs (using Ubuntu and have installed all necessary packages) and compile the equalizer examples without CMake. I just made a new Eclipse GCC project and added the examples.
eqHello for example can be compiled without any problem also my own project can be compiled with 0 errors.
Now the problem is, I get a segmentation fault once I start the application. I tested the same thing in Visual Studio and it also crashes with a segmentation fault!
Does anyone in the list has experience with eclipse and equalizer without using CMake or has anyone an advice what probably goes wrong?
Maybe I have to use a specific compiler setting?
I just had a look at the CMakeLists files, but it does not really help me out!
Maybe someone could zip me an example eclipse project with working eqPly?

Thanks in advice, hope anyone can help me.

Sincerely,
Andreas
Reply | Threaded
Open this post in threaded view
|

Re: Problems with building the project without CMake

Stefan Eilemann
Hi Andy,

On 17. Oct 2012, at 14:32, "Andy1988 [via Software]" <[hidden email]> wrote:

> I am currently working on a project using equalizer. I tried to use CMake (Buildyard) to build the whole equalizer project from github. That works all fine. The thing is, I want to use the installed libraries of equalizer in my system libs (using Ubuntu and have installed all necessary packages) and compile the equalizer examples without CMake. I just made a new Eclipse GCC project and added the examples.
> eqHello for example can be compiled without any problem also my own project can be compiled with 0 errors.
> Now the problem is, I get a segmentation fault once I start the application. I tested the same thing in Visual Studio and it also crashes with a segmentation fault!
> Does anyone in the list has experience with eclipse and equalizer without using CMake or has anyone an advice what probably goes wrong?
> Maybe I have to use a specific compiler setting?

Does it also crash if you build eqPly with the provided CMakeLists? It should not, I tested this during the 1.4 release.

Can you run it with 'EQ_LOG_LEVEL=INFO' to get a clue where it crashes? My next step would then be to run under gdb to see if I get something useful (likely not), then build debug libraries and drop them in place and run again under gdb.

If you post the INFO log output and 'thread apply all bt' from gdb I might be able to help you. Put them on gist.github.com if they are too big for email.


Cheers,

Stefan.